Find a Bug, Get it Free (This has ended)

Find a Bug, Get it Free (This has ended)

New postby marwatk on Wed Feb 03, 2010 7:34 pm

Contest Over

Thanks to all that helped, you should be receiving your codes via private message.

I want to make this app solid, so I'm going to run an experiment.

If you find a bug in VersaTool, you get a free copy.

I want to be fair to both you and me, so here are the rules:

  • I can discontinue this at any time: I have no idea how this is going to work out, so this rule is just CYA :)
  • I may change these rules at any time: I want to be fair, but I'm not a lawyer so I probably screwed this up
  • Limit one free registration code per person: Though definitely keep sending in bug reports if you find them
  • Must be a real bug: It should be obvious that something is broken or doesn't do what it looks like it should do. Requests for features, behavior changes or unintuitive behavior don't count (but send it in, and if it's good enough I may give you credit for it)
  • Your bug report must be made in the VersaTool 'Bugs and Help' forum to count: I'll take bugs via email, but the first person posting a given bug to the *forum* is who gets credit for it. If I get your email and no one has yet posted in the forums about it, you'll get credit, but if your email came in first but someone posted it to the forums before I read your email, they get credit. (Trying to be transparent, that's why I'm trying to keep it in the forums)
  • Only the first person to find a given bug gets a free code: I'll be updating this post with bugs that are found once a day. But that's not an exhaustive list because I expect people will be posting bugs throughout the day. The first report of a given bug gets the credit.
  • Anything on the 'fixed' lists are fair game for re-reporting as a new issue (and credit for them), since if it's on the fixed list I thought I fixed it, so it's technically a new bug

To be eligible you must be a *registered* forum poster, since that's the only way I can track this easily. I'll be keeping track of all of the forum users that have qualified for a free copy and send private messages to them via the forum when I have the registration infrastructure in place.

If anyone sees any huge loopholes or gotchas in the above, let me know.

Happy bug hunting!

(Note: This topic is locked to prevent all the reports going into a single huge topic, post your bugs in a new topic under this forum)

-Marcus

[b] Current known issues
(as of Feb 6):

  • Eliminate 'is' match criteria on the 'from' field in AutoReply
  • Tip calculator produces garbage results with totals over 10,000,000 (Anguish) 2/[email protected]:21
  • 'Run App' home screen icons don't use app's icon (Anguish) 2/[email protected]:20

Can't/won't fix:
These items are either very hard to fix for the benefit, or OS issues that can't be controlled...
  • -whenever I'm in the app and on the main screen placing my finger on the edge of the screen selects an item on the opposite edge. clicking on the edge will open the mis-selected item. (Red261 on Thu Feb 04, 2010 9:55 pm)
  • Floating point issues in unit conversion (skipcuda on Fri Feb 05, 2010 10:31 am )
  • 9550 (.320). V 1.13. The take a picture is still acting like it did before with the screen having the green lines (now with purple) and the window the same after, having the center of the screen showing the page below, which was the VT home page (using the take a picture icon there) but if I move around the screen it will bring some back. If backed out it cleared. I should say that was the only time after that it did not work at all. When trying to take the pic from either the home page or bookmarks of went to the preview, then asked for permissions, hitting allow would just repeat without any action. Hitting deny did nothing either. Trying to end or to back out had to take repeated attempts to get it to clear. No photo taken at any on these. Battery pull made no difference. (skipcuda on Tue Feb 09, 2010 9:05 am)

Pending:
  • Just take a picture can sometimes block media player actions (marwatk)
  • BB Tour with 4.7 I cannot get the left or right convenience key shortcuts (double-tap and hold) to work. (innov8) 2/[email protected]:49
  • Error running menu item! net.rim.decive.api.system.ApplicationMangerException: Error starting null: null" from adding the BB stander app to the popup menu and try running it (Storm 9530 World Edition @ 5.0.0.419) (PhamO on Fri Feb 05, 2010 1:36 am )

Fixed in 0.1.14
  • the alarm setting worked great yesterday when i tested it multiple times. but when the phone is in "bedside mode" it doesn't ring or vibrate at all. curve 8330 released 5.0.0.438 (jonhedge1 on Fri Feb 05, 2010 6:12 am)
  • 8330/BB Dimension L theme. the area available for the icon is so small that the high (60) and low (36) temperatures overlap such that I see (red 6)(blue 3)(blue 6). (ximinez on Sat Feb 06, 2010 4:38 pm)
  • now when i take a picture a big black square appears in the middle of the screen and requires a battery pull to make it go away even though i can exit out of VT completely...i can see the bb home screen behind it. curve 8330 5.0 (released) (jonhedge1 on Sun Feb 07, 2010 5:35 am)
  • 9550 (.320) V .1.12 If I launch from the VT home screen the weather will work fine and the updates seem to work. I set it as a 'Dbl Escape' Convenient key and when I try to run it from there, I got a white screen stating "no data" on the top, and "updating" on the bottom. After it tried loading for a while I got an alert "uncaught exception: Application VersaTool (168) is not responding: process terminated". When I tried to use the other Conv. keys, they did not respond. After a battery pull I changed the city, all keys worked, tried the Dbl for weather and the exact same thing happened again.
  • I discovered this moring that teh alarm doesn't work if the phone is powered off unlike the phones built in alarm. The diversity of the many alarms is great, however the alarm needs to be able to wake up the phone (dlipton on Tue Feb 09, 2010 7:25 am)
  • Having the instructions right on the permissions screen is really cool! But I can't scroll down far enough to read it all because I get sort of stuck on the yes/no buttons. "No" highlights and I can't scroll far enough down. (Quempas on Tue Feb 09, 2010 8:31 am)

Fixed in 0.1.13
  • I wanted to edit the (default) popup menu to get rid of take a picture and insert "global search". I removed take a picture typed in "bb search..." and selected "run app" and then "global search". Save and then exit and test - tests ok. Now, when I go into edit popup menu again, my new label "bb search..." says "run app" ... "addressbook". (mrcoyote on Sun Feb 07, 2010 8:17 am)
  • The pop up menus aren't remembering what applications I have selected. When I go back into VersaTool and click on Popup Menus, then select the menu I want to edit, all of the entries point back to the first application in the list. (frasej on Mon Feb 08, 2010 12:06 pm)
  • hope to see it update a lot more often than 6 hours - (makes "current conditions" pointless if it doesn't update often) (mrcoyote on Sat Feb 06, 2010 7:50 am )
  • Tour, OS 5.0.0.419 I must go into each module's permissions, set to "deny", then set to the (top, bold) allow setting. The built in popup offers to set permissions for me, but it never does so. (Quempas on Sat Feb 06, 2010 4:21 pm)

Fixed in 0.1.7
  • one problem is with the "just...picture"; i get a big black square in the middle of the screen that does nothing. i have to actually exit the whole app to get it to go away. i can't just back out (jonhedge1) 2/[email protected]:43
  • "Just take the picture" resulting picture is messed up on the Storm2 (skimore2020) 2/[email protected]:45
  • Tried it out before sleeping to see if the camera works but still shows the same null error. Also, convenience keys still not working. (dx169 on Sat Feb 06, 2010 1:00 am)
  • I have temp's to Celcius - in the weather forecast I still get Celcius labelled icons, but the current and forecasted temps are in Fahrenheit (mrcoyote on Sat Feb 06, 2010 7:50 am )
  • from the weather icon in the VT UI, everything shows Fahrenheit despite my prior configuration to Celcius. (mrcoyote on Sat Feb 06, 2010 7:50 am)

Fixed in 0.1.6:
  • I got a popup "uncaught exception: task already scheduled or cancelled". This was when i hung up from a phone call (cgiforever) 2/[email protected]:24
  • The "run on schedule app" will not run two apps placed on the same time such as the BB alarm and BB browser. (only two apps i have tested so far) And short timing with two apps , I tested about a 1 min gap will cause only the 1st one open as well. (PhamO) 2/[email protected]:53
  • Sometimes really convenient keys don't work until after a reboot
  • if you're editing a response email, but you go in to insert a canned response, but don't, your message no longer feels that it's 'edited' and lets you back out without saving it (ofutur) 2/[email protected]:46
  • Also, the text entry interface while putting the URL in was funky...keyboard kept coming up over the entry field. And I could only see one character of what I typed. (roybaum) 2/[email protected]:33
  • editing convenience keys deletes them. (c0rinne on Fri Feb 05, 2010 9:09 am)
  • When I am in the Unit Conversion App, I found that when I input 1 year, it's giving me 43.9794172 days! When I input 365 days, it gives me 8.2993688 years! (jkwong8623 on Fri Feb 05, 2010 9:14 am)
  • When using the "Run On Schedule" function for the weather, I get the following message: "Retrieved: Wed Dec 31 16:00:00 America/Los_Angeles 1969" (bloodbath on Thu Feb 04, 2010 10:25 pm )
  • When editing a menu, for example, its name, instead of editing the current menu it creates a second entry, a duplicate. So instead of having one revised menu, you have two of the same menu except one is the older menu and the other has the change that you apply. (dx169 on Thu Feb 04, 2010 6:54 pm )
  • I'm running OS 5 on a Tour. Not all of the applications are showing up when you create, well, anything that launches an app. Examples are Profiles, DeviceInfo, Bluetooth and others. It appears that a lot of the lower level, system applications are missing from the list. (frasej on Fri Feb 05, 2010 11:17 am )


Fixed in 0.1.3:
  • Error taking picture: javax.microedition.media.MediaException:Requested format not supported. (jlawler4) 2/[email protected]:33
  • When I google search from the shortcut, no matter what I type in, it just searches for the word "search" (jlawler4) 2/[email protected]:35
  • Font issues with day selection makes it impossible to see days selected with certain fonts (Toneberry24) 2/[email protected]:36
  • When saving a new location, the message "Updating weather" stays at the bottom of the page, even though the stats seem to change. (ofutur) 2/[email protected]:37
  • "Just take the picture" has trouble running from a home screen icon (Toneberry24) 2/[email protected]:36
  • Bold 9700 running OS 5.0.0.330. I am having the following problems with it. The try it feature or the alarm itself will not play any tone, whether it is the included, wma, or mp3 files (jline4) 2/[email protected]:22
  • Editing the title of a homescreen bookmark reports that it already exists (in the case of the weather app) (KRH20) 2/[email protected]:17
  • "Uncaught exception: object already exists" when pressing on the weather icon on the homescreen (ofutur) 2/[email protected]:05
  • I set Take a Picture as a bookmark. When I click on the icon, it shows an error "Uncaught exception: object already exists." (dx169) 2/[email protected]:04
  • UI engine accessed without holding the event lock in weather (arkolbus) 2/[email protected]:46
  • in the "weather for.." part when i first loaded it this am it would display the the highs and lows for the day right on the icon...it stopped doing that. not sure why or if i might have accidentally changed a setting.it recently just came back... (jonhedge1) 2/[email protected]:49
  • I went back in to the "Home Screen Bookmarks" section of the app to delete my duplicate shortcut. It just sits at "Loading" with an empty list now. I can still load the menu, but the options don't do anything at this point. (talon8) 2/[email protected]:22
  • the font color is also white when you creating folders in the Canned Responses area as well. (c0rinne) 2/[email protected]:00
  • Popup menus should detect that there's one already open and not open a second
  • Popup menu should default to double press 'End' not press
  • I went to the "Add a Homescreen" app and tried to add a "Take a picture". When I press "back" it asks me if I want to save and I say yes, but it doesn't leave the page. If I press "discard" nothing gets created. (ofutur) 2/[email protected]:46
  • From searching from Wikipedia is fine but once you hit the end-key it brings you back to the homepage with three options menu open and the keyboard open and will not go away.(a battery pull got it to leave) (PhamO) 2/[email protected]:02
  • Editing Convenience Keys Creates a copy (talon8) 2/[email protected]:10
  • Editing a existing bookmark seems to create a copy (like editing convenience keys). In this case, I had it set to launch a URL. I modified the actual URL. (talon8) 2/[email protected]:22
  • On my Bold 9000 running OS 5.0, when typing the criteria for the Auto Reply, what you are typing does not appear in the box until you are done typing and return to the Edit Auto reply page. (Rumur) 2/[email protected]:37
  • I set it to "Compose" instead. When I tried to run it I got "Error running action for shortcut key! net.rim.device.api.system.ApplicationManagerException: Error starting null: null" (talon8) 2/[email protected]:58
  • When I add the BB "Compose" to the pop up menu and tried to run it i got this "Error running menu item! net.rim.decive.api.system.ApplicationMangerException: Error starting null: null" This Error also shows when "altMusic, altPictures, altVideos", "Files" "Music" "net_rim_bb_clock" "Pictures" "SavedMessages" "Videos" (PhamO) 2/[email protected]:46
  • Home screen shortcuts for weather and tip calculator are displaying on the home screen with the title versatoollauncherx (the_rick311) 2/[email protected]:10
  • Popup menus don't work as home screen icons (marwatk)
  • Permissions dialog can hang the UI process (Macapple) 2/[email protected]:42
  • 9700/5.0.0.415 : trackpad response is extremely slow and jumpy. Small movement on the pad may cause the icon to jump across entire screen. (maddmaxx308) 2/[email protected]:55
  • Launchers are titled LauncherX on Pearl 8120 @ 4.5.0.124 (jsolts) 2/[email protected]:43

Fixed in 0.1.2:
  • Creating a home screen bookmark directly from the browser is broken (marwatk) - Fixed as of 0.1.2

Misc user help list:
rebroker
Red261 on Sat Feb 06, 2010 7:50 pm
dx169 on Sat Feb 06, 2010 8:19 pm
Versatile Monkey
For more/quicker help make sure to check out the user manuals
marwatk
Lead (and only) Monkey
 
Posts: 2596
Joined: Sun Nov 02, 2008 9:20 pm

Return to Bugs and help

Who is online

Users browsing this forum: No registered users and 1 guest

cron